Dynamic Host Configuration Protocol (DHCP) je skup pravila za komunikacijske uređaje, kao što su računar, router ili ostale vrste mrežnih adaptera, pomoću kojih uređaj može zahtijevati i dobiti odgovarajuću IP adresu sa servera.
DHCP je protokol korišten od strane mrežnih računara za dobijanje IP adresa i ostalih mrežnih postavki kao što su pretpostavljeni gateway, subnet maska, i IP adrese DNS servera sa DHCP servera. Olakšava konfigurisanje mreže jer eliminiše ručno dodavanje osnovnih postavki za jednu računarsku mrežu. DHCP server osigurava da su dodijeljene IP adrese posebne, i brine se da u mreži nema sukoba.
DHCP je prihvaćen kao standardni protokol u oktobru 1993. godine. Posljednja definicija datira iz marta 1997. godine. Najnovija nestandardna verzija protokola koja opisuje DHCPv6 u novom IPv6 okruženju je predstavljena u julu 2003. godine.
Također pogledajte Reverse Address Resolution Protocol
Reference
Vanjski linkovi
RFC 2131 - Dynamic Host Configuration Protocol RFC 2132 - DHCP opcije DHCP RFC - Dynamic Host Configuration Protocol RFC (IETF) Sigurnost DHCP servera RFC 4242 - DHCP za IPv6 DHCP Sekventni dijagrami RFC 3046, Opis kako DHCP opcija 82 radi RFC 4361 - DHCPv4 DHCP protokolne poruke
Kategorija:Mrežni protokoli