Sähköposti tarkoittaa digitaalisten, yleensä kirjallisessa muodossa olevien viestien välittämistä tietokoneilla nimetyille vastaanottajille. Viestit säilötään lukemista varten. Viestit välitetään tietyillä protokollilla useimmiten tietoverkkoon vähintään postin lähettämisen ja noutamisen ajaksi kytkeytyvien tietokoneiden välillä. Sähköposti on nopea ja helppo tapa tavoittaa vastaanottaja. Sähköpostia käytetään myös henkilökohtaiseen tiedostojen tallentamiseen ja varmuuskopioimiseen.
Sähköpostia välitetään Internetissä tietokoneiden välillä SMTP-protokollan avulla. Sähköposti luetaan asiakasohjelmalla, joka voi olla tietokoneen työpöytäohjelma tai selaimessa pyörivä web-sovellus. Asiakasohjelma hakee sähköpostin palvelimelta POP3 ja IMAP-protokollalla, joita melkein kaikki sähköpostiohjelmat tukevat.
Historiaa
Sähköposti oli olemassa ennen tietoverkkoja. Varhaisiin keskustietokoneisiin oli kytkettyinä usea pääte ja niitä voi käyttää usea käyttäjä. 1960-luvulla kehitettiin sähköpostijärjestelmiä, joilla toisille koneen käyttäjille voi lähettää viestejä. Tenex-käyttöjärjestelmässä oli käsky SNDMSG, joka lähetti viestin toisen käyttäjän hakemistoon tiedostoon nimeltä MAILBOX. Postin voi lukea tulostamalla tiedosto ja poistaa editoimalla sitä tekstieditorilla. Käyttäjän kirjautuessa järjestelmään se ilmoitti jos käyttäjälle oli tullut sähköpostia. SRI Internationalin Dick Watson ehdotti 1971 "Mail Box Protocol" -määritelmää (RFC-196), jolla dokumentteja voisi lähettää kaukokirjoittimella tai muulla kirjoittimella tulostamista varten. BBN:n Ray Tomlinson piti tätä turhana ja halusi käyttäjän päättävän dokumentin tulostamisesta. Tomlinson kehitti ohjelman, jolla tiedoston voi kopioida toisen käyttäjän postilaatikkoon eri koneella Arpanetin yli. Tomlinson päätti myös käyttää @-merkkiä yhdistämään käyttäjän ja tietokoneen nimi. Näin user@remote oli sähköpostiosoite verkossa.
ARPA:n johtaja Larry Robert kirjoitti ensimmäisen varsinaisen ohjelman nimeltä RD sähköpostin lukuun TECO-tekstieditorin makrokielellä. Sen avulla voi listata sähköpostilaatikossa olevat viestit, valita niistä luettavan ja printattavan. Vuoden 1973 lopulla sähköposti oli jo yleisessä käytössä Arpanetissa. Aluksi Tenexin CPYnet-tiedostonsiirto-ohjelma korvattiin FTP:llä. FTP:hen lisättiin MAIL-käsky (myöhemmin APPEND) tiedoston kopioimiseksi postilaatikkoon. Tässä vaiheessa sähköpostin muotoa ei oltu vielä standardoitu, vaan viestien välillä käytettiin neljää Control-A-merkkiä (SOH, Start of Header). Sähköpostin standardointia tehtiin jo vuonna 1973 (): jokaisessa viestissä piti olla vähintään kolme kenttää alussa: From, Subject ja Date (lähettäjä, aihe ja päivämäärä). Tämän seuraajaksi tuli RFC-680 ja vuonna 1976 RFC-724 ja RFC-733, joka oli käytössä 1980-luvulle.
Uudet sähköpostijärjestelmät käyttävät kansainvälisiä verkkoja, kuten internet. Vuonna 1980 julkaistu kuvaa aiottua siirtymistä ARPANETistä Internetiin. Tuloksena syntyivät vuonna 1982 SMTP () viestien siirtoa varten ja sähköpostin muodon kuvaava , joihin nykyinen sähköposti perustuu.
Nykyisin sähköpostin tietoturvaa on parannettu eri tavoin. Vuonna 2011 määriteltiin DomainKeys Identified Mail (, päivitetty ja ), jonka on tarkoitus estää postin lähetys väärennetyillä osoitteilla. Tämä on yksi kolmesta autentikaatiomenetelmästä (SPF, DKIM ja DMARC), joiden on tarkoitus estää väärennetyt viestit.https://learn.microsoft.com/en-us/microsoft-365/security/office-365-security/email-authentication-dkim-configure
DMARC (Domain-based Message Authentication, Reporting and Conformance, ) lisää DNS-nimipalveluun ohjeet, miten vastaanottaja voi autentikoida tulevan sähköpostin, joka väittää tulevansa määrätystä verkkotunnuksesta.
SPF (Sender Policy Framework, ) listaa nimipalvelussa verkkotunnuksen sallitut isäntänimet ja IP-osoitteet, joista sähköpostia lähetetään.
Näiden käyttö on nykyisin lähes pakollista, sillä Google alkoi vaatia DKIM:in käyttöä Gmailiin lähetettävistä massaviesteistä helmikuussa 2024.https://blog.google/products/gmail/gmail-security-authentication-spam-protection/
Ohjelmat Sähköpostin käsittelyyn liittyviä ohjelmia ovat asiakasohjelma, jolla käyttäjä lukee sähköpostia (Mail User Agent, MUA), välitysohjelma (Mail Transport Agent, MTA) ja palvelinohjelma (Mail Delivery Agent, MDA).
Asiakasohjelma (MUA) käsitetään sähköpostin lähteenä ja kohteena: asiakasohjelma antaa sähköpostin välitysohjelmalle (MTA) (). Palvelinohjelma kerää viestit ja odottaa käyttäjän hakevan viestit asiakasohjelmalla. MTA-ohjelmat käyttävät SMTP-protokollaa ja siksi kutsutaan usein SMTP-palvelimiksi ja MDA-ohjelmia kutsutaan POP- ja IMAP-palvelimiksi.
center|Havainne sähköpostiohjelmista.
Sähköpostin edut
Sähköposti on nopea, edullinen ja vaivaton viestintätapa. Tavalliseen kirjeeseen verrattuna suurin etu on sen nopeus.
Sähköpostiviesti menee perille sekunneissa tai muutamassa minuutissa maapallon toiselle puolelle, yleensä Internet-verkkoa hyväksi käyttäen. Sähköposti voidaan saada myös sinne, minne Internet ei ulotu, esimerkiksi hakemalla ja lähettämällä viestit puhelinyhteyden kautta, kuten aikoinaan ennen Internetin yleistymistä.
Kustannuksiltaan sähköposti on huomattavasti tavallista kirjettä halvempi. Käyttäjä maksaa usein vain internetyhteyden tietokoneellensa. Verkkoyhteyden ei tarvitse olla auki kirjettä kirjoitettaessa, vaan viestin voi laatia valmiiksi ennen yhteydenottoa sähköpostipalvelimeen. Kun kirje on valmis, otetaan yhteys verkkoon, lähetetään viesti vastaanottajalle ja haetaan samalla mahdolliset itselle osoitetut viestit; yhteys ei näin usein kestä minuuttiakaan. Tietokoneella oleva ohjelma voi tehdä tämän automaattisesti aina yhteyden syntyessä, mikä on kätevää myös kannettavilla tietokoneilla. Tavalliseen kirjeeseen verrattuna käsittelykustannukset jäävät pieniksi: kopiointia, kirjekuoria ja postimerkkejä ei tarvita, eikä kenenkään tarvitse edes nousta pöytänsä äärestä.
Puhelimeen verrattuna sähköpostin etu on vastaanottajan saavutettavuus. Vaikka vastaanottaja ei olisikaan heti tavoitettavissa, sähköposti voidaan lähettää odottamaan. Kun vastaanottaja tarkastaa postilaatikkonsa, on sähköposti odottamassa häntä.
Sähköposti on myös helppo tallentaa ja tarkistaa jälkikäteen.
Sähköpostin lukumahdollisuus on lisätty myös mobiililaitteisiin ja matkapuhelimiin sekä älypuhelimiin ja taulutietokoneisiin. Tähän liittyen on kehitetty Push Email.
Ongelmat
Sähköposti kulkee verkossa yhä usein selväkielisenä, ellei viestiä erikseen salata. Salatunkin viestin "kuoressa" kulkevat tiedot (lähettäjä ja vastaanottaja yms.) ovat näkyvillä. Toisaalta kirjesalaisuus koskee myös sähköposteja ja verkon salakuuntelu ei onnistu helposti kuin lähiverkossa ja teleoperaattoreiden tiloissa. Salakuuntelun mahdollisuus on kuitenkin hyvä pitää mielessä, jos haluaa suojautua vakoilulta.
Suurena ongelmana on roskaposti, joka tukkii postilaatikoita mainoksilla tai muuten epätoivotuilla viesteillä. 2000-luvun alussa 75–90 % verkossa liikkuvasta sähköpostista oli roskapostia. Sähköpostia suodatetaankin eri tavoilla roskapostin torjumiseksi. Jotkut käyttävät myös ensisijaisen sähköpostiosoitteensa rinnalla toista, rajummin suodatettua osoitetta, niissä yhteyksissä, missä käyttäjä epäilee osoitteen helpoiten joutuvan roskapostaajien listoille.
Myös haittaohjelmat voivat levitä sähköpostin välityksellä. Jotta viesti näyttäisi asialliselta, haittaohjelma voi lisätä viestiin tietokoneelta löytämiään, mahdollisesti salassa pidettäviä tai arkaluonteisia, asiakirjoja.
Joskus sähköpostiviesti voi hävitä, joko väärin säädetyn palvelimen asetusten tai liian tiukan roskapostisuodattimen takia. Tämä on kuitenkin epätavallista, ellei viesti ole huolimattomasti laadittu, niin että se muistuttaa roskaposteja. Mahdollisia omia roskapostisuodattimia kannattaa säätää varovasti, etteivät ne hävitä postia.
Eräs ongelma on myös vastaanottajan osoite. Osoitteen on oltava tarkasti oikein, jotta viesti saavuttaa vastaanottajan. Väärin kirjoitettu osoite johtaa yleensä viestin palauttamiseen lähettäjälle (kunhan lähettäjätiedot ovat kunnossa), ellei käytetty osoite kuulukin toiselle henkilölle. Sähköpostiohjelmissa on yleensä tuki osoitekirjalle ja muille tavoille hakea osoite automaattisesti, jolloin kirjoitusvirheet vältetään. Sähköpostiosoite lisätään usein käyntikorttiin tai kirjelomakkeeseen.
Pitkissä, useiden ihmisten välisissä keskusteluissa ongelmaksi muodostuu vaihtelevat tavat lainata aiempia viestejä. Joidenkin mielestä erityisesti top-postaus on häiritsevää, koska se vaikuttaa keskustelun seuraamiseen. Top-postaaminen voi myös olla tietoturvariski, jos viesti lähetetään eteenpäin kaikkine aiempine lainauksineen näitä tarkistamatta.
Sähköpostin rakenne Sähköpostiviesti alkaa otsaketiedoilla (engl. header), joissa kerrotaan lähettäjä ja vastaanottaja, viestin aihe, viestin muoto (tekstin koodaus, onko liitteitä jne.), onko viesti vastaus toiseen yms. Näitä seuraa tyhjä rivi, jonka jälkeen tulee itse viesti. Jos viesti koostuu useammasta osasta (esimerkiksi jos siinä on liitteitä), jokaista osaa edeltää vastaavasti ryhmä otsakkeita, jotka kuvaavat kyseistä osaa. Sähköpostiohjelma näyttää näistä tiedoista vain sen, minkä tulkitsee oleelliseksi, ellei erikseen pyydä kaikkea näkyville. Jotkut ohjelmat myös esittävät otsakkeiden nimet käyttöliittymän kielelle käännettyinä.
Sähköpostimaailma on vielä paikoin 7-bittinen, joten mahdolliset ASCIIhin kuulumattomat merkit pitää koodata ainakin otsaketiedoissa. Yleensä sähköpostiohjelma huolehtii tästä, mutta joskus näkee ääkkösten korvaantuneen kysymysmerkeillä, X:illä tms. Ääkköset sähköpostiosoitteissa voivat aiheuttaa myös ongelmia, koska useat sähköpostiohjelmat eivät ole IDN-tuella varustettuja.
Kun viesti lähetetään palvelimen kautta maailmalle, viestiin lisätään "kuori" (katso viestinvälitysprotokolla SMTP laajennoksineen), jonka perusteella palvelimet päättelevät minne viesti pitää lähettää ja mitä tehdä virhetilanteissa. Vastaanottajan sähköpostipalvelin tallettaa viestin (ilman kuorta) vastaanottajan sähköpostilaatikkoon, jossa se on luettavissa tai noudettavissa vastaanottajan sähköpostiohjelmalla.
Lähettäjätiedot From: henkilö(t) tai toimi, jonka puolesta sähköposti lähetetään; usein tämä on ainoa lähettäjätieto Sender: henkilö (tai robotti), joka lähettää viestin, jos muu kuin yllä mainittu tai kun viesti lähetetään useamman henkilön puolesta; virheilmoitukset lähetetään tähän osoitteeseen Resent-From, Resent-Sender: jos viesti on edelleenlähetetty sellaisenaan, eikä "forward"-toiminnolla, (postituslista, väärä osoite yms.) edelleenlähettäjä kuvataan joskus näillä tiedoilla Reply-To: osoite, johon vastaukset halutaan, esimerkiksi silloin, kun viesti lähetetään postituslistan kautta ja vastaukset halutaan joko listalle tai itselle vastoin listan käytäntöjä, tai kun halutaan kopio toisellekin henkilölle.
Osoitekentissä sähköpostiosoitteet kirjoitetaan joko sellaisinaan tai, jos myös henkilön nimi halutaan kirjoittaa, kulmasulkeissa. Sähköpostiosoitteet ovat lähettäjätiedoissa pakollisia. Kommentteja voi kirjoittaa kaarisulkeisiin, mutta tätä ei suositella, koska jotkut sähköpostiohjelmat tulkitsevat kommentit niminä. Osoitteet erotetaan pilkulla. From: Jari Jokunen (kommentti) <[email protected]>, Matti =?iso-8859-1?Q?Meik=E4l=E4inen?= <[email protected]> Sender: [email protected]
Osoitekentissä ei saa olla kuin ASCII-merkkejä, miksi muut merkistöt pitää koodata, ilmoittaen merkistön ja koodauksen, tässä iso-8859-1 ja quoted printable. Lukijalle nimi näkyy oikein: Matti Meikäläinen. Erikoismerkeille harvemmin on käyttöä, mutta niiden esittämiselle on omat sääntönsä. Tyhjällä alkavia jatkorivejä saa käyttää. Yleensä sähköpostiohjelmat hoitavat tarvittavan koodauksen, mutta joskus, varsinkin erikoisemmissa tapauksissa, koodaus voi epäonnistua.
Vastaanottajat To: viestin varsinainen vastaanottaja CC: tiedoksi ("carbon copy", "kopio")