vignette|Représentation graphique de tous les types d'enregistrements DNS.
Voici une liste des enregistrements DNS (Domain Name System) et leur utilité.
Liste des enregistrements
Voici la liste officielle des enregistrements DNS disponibles sur le site de l'IANAListe de l'IANA, Liste officielle des enregistrements DNS sur le site de l'IANA..
Enregistrement Code IANA RFC Statut Signification FonctionA1 RFC 1035actifAddress IPV4Renvoie une ou plusieurs adresses IPv4 pour un nom d'hôte donné.AAAA28RFC 3596actifAdresse IPv6Renvoie une ou plusieurs adresses IPv6 pour un nom de domaine donné.NS2 RFC 1035actifName ServerDélègue la gestion d'une zone à un serveur de nom faisant autorité AFSDB18 RFC 1183actifAXFR252RFC 1035 RFC 5936actifTransfert de zoneMD3 RFC 1035OBSOLÈTEMF4 RFC 1035OBSOLÈTECNAME5 RFC 1035actifCanonical NAMEPermet de réaliser un alias (un raccourci) d'un hôte vers un autre.SOA6 RFC 1035actifStart Of AuthorityDéfinit le serveur maitre du domaine.MB7 RFC 1035EXPÉRIMENTALMG8 RFC 1035EXPÉRIMENTALMR9 RFC 1035EXPÉRIMENTALNULL10 RFC 1035EXPÉRIMENTALWKS11 RFC 1035actifWell Known ServicePTR12 RFC 1035actifPointerRéalise l'inverse de l'enregistrement A ou AAAA : donne un nom de host (FQDN) pour une adresse IP.HINFO13 RFC 1035actifHost informationPermet de spécifier le type de CPU (processeur) et le système d'exploitation de l'hôte concerné.MINFO14 RFC 1035actifMail InformationIndique l'adresse mail du responsable du domaine mail ainsi que l'adresse à contacter en cas d'erreur.MX15 RFC 1035actifDéfinit le nom du serveur de courrier du domaineTXT16 RFC 1035actif Texte Permet d'enregistrer du texte non-structuré..RP17 RFC 1183actifResponsible PersonDéfinit une personne responsable du serveur (il y a toujours un champ TXT lorsqu'il y a un champ RP).X2519 RFC 1183actifISDN20 RFC 1183actifRT21 RFC 1183actifNSAP22 RFC 1706actifNSAP-PTR23 RFC 1348actifSIG24 RFC 4034 RFC 3755 et RFC 2535actif DNSSECKEY25 RFC 4034 RFC 3755 et RFC 2535actif DNSSECPX26 RFC 2163actifGPOS27RFC 1712actifLOC29RFC 1876actif Localisation géographiqueNXT30RFC 3755 et RFC 2535OBSOLÈTEEID31PattonactifNIMLOC32PattonactifSRV33RFC 2782actifPermet de définir un serveur spécifique pour une application, notamment pour la répartition de charge.ATMA34ATMDOCactifNAPTR35RFC 2915 RFC 2168 RFC 3403actifKX36RFC 2230actifCERT37RFC 4398actifA638RFC 6563 RFC 3226 RFC 2874HISTORIQUE Adresse IPv6DNAME39RFC 2672actif Delegation Name Alias pour un nom et tous ses sous-nomsSINK40EastlakeactifOPT41RFC 2671actif EDNS Extensions DNS comme l'augmentation de la taille des paquets.APL42RFC 3123actifDS43RFC 4034 RFC 3658actifDNSSECSSHFP44RFC 4255actifIPSECKEY45RFC 4025actifRRSIG46RFC 4034 RFC 3755actif DNSSEC"Resource Record Signature" contient la signature numérique d'un RRset.NSEC47RFC 4034 RFC 3755actif DNSSECDNSKEY48RFC 4034 RFC 3755actif DNSSECContient la clé publique utilisée pour signer un RRSIGDHCID49RFC 4701actifNSEC350RFC 5155actif DNSSECNSEC3PARAM51RFC 5155actif DNSSECHIP55RFC 5205actif Host Identity ProtocolNINFO56ReidactifRKEY57ReidactifTALINK58WijngaardsactifSPF99RFC 7208OBSOLÈTELe code 99 est obsolète. Le SPF doit être entré dans le champ TXT. Voir RFC7208, section 3.1UINFO100IANA-ReservedactifUID101IANA-ReservedactifGID102IANA-ReservedactifUNSPEC103IANA-ReservedactifTKEY249RFC 2930actifTLSA52RFC 6698actifTLSA certificate associationUn enregistrement pour l'authentification d'entités nommées basée sur DNS (DANE).TSIG250RFC 2845actifIXFR251RFC 1995actifMAILB253RFC 1035OBSOLÈTEMAILA254RFC 1035OBSOLÈTE*255RFC 1035actifCAA257RFC 6844actifDNS Certification Authority AuthorizationPermet d'indiquer aux autorités de certification quelles sont celles autorisées à certifier le domaine.TA32768Weiler Weiler.actifDLV32769RFC 4431actifDNSSEC Lookaside ValidationPrivate use65280-65534
Notes et références
Voir aussi Articles connexes Domain Name System : système de noms de domaine Enregistrement Mail eXchanger : enregistrement MX (Mail eXchanger) Enregistrement SRV (service)
* Catégorie:Protocole réseau sur la couche application