Az Internet Protocol version 6 (IPv6) az internetprotokoll (IP) új verziója, melyet az Internet Protocol version 4 (IPv4) leváltására terveztek.

Az IETF (Internet Engineering Task Force) által kezdeményezett kutatások lényege az új protokoll kifejlesztésére a 4-es verziójú (IPv4) címek előrelátható kimerülése volt. Ahogy az internetezők és az általuk használt eszközök száma egyre bővül, a kiadható IP-címek száma egyre csökkenő tendenciát mutat. Ez a nagy cégek és intézmények számára okozhatja a legtöbb gondot, de a későbbiekben minden felhasználót érinthet. Számos igen hatékony hálózati megoldás született a múltban (CIDR: Classless Interdomain Routing, NAT: Network Address and Port Translation stb.) annak érdekében, hogy az IPv4 címek fogyásának ütemét csökkentsék, ám az internet terjedésének köszönhetően ma már nyilvánvaló, hogy a rendelkezésre álló szabad IPv4-tartomány belátható időn belül elfogy. Az IPng-vel (IP new generation) szemben támasztott követelmények lényege volt, hogy egyszerűen és gyorsan be lehessen vezetni, valamint a régi rendszer az újjal párhuzamosan tudjon működni. Az IPv4 esetében használatos 32 bites címzéssel szemben (hálózatszervezési okokból az IP-címek egy része nem is használható), az IPv6 címek 128 bitesek, így a nagyságrendekkel nagyobb címtartomány révén az új rendszer közvetlenül címezhetővé teszi az internethez kapcsolódó eszközöket.

Az első IPv6-tal foglalkozó szabványok 1992 decemberére készültek el, és a hét változatból 1994-re született meg a ma IPv6-nak nevezett protokoll, amelyet 1994. november 17-én az Internet Engineering Steering Group is elfogadott és felhasználásra javasolt.(A jelenleg használt IP verzió a 4-es. Az IPv5-ös verziója, egy köztes munkaverzió volt és teljesen más célt szolgált volna (összeköttetés alapú kiegészítés az IPv4-hez), azonban a gyakorlatban sohasem terjedt el).

2011. június 8-ára ismert tartalomszolgáltatók, mint a Google, a Facebook és a Yahoo világméretű tesztnapot kezdeményeztek, "World IPv6 Day", azaz az IPv6-világnap néven.

Az IPv6 magyarországi mérföldkövei

A BME Folyamatszabályozási Tanszékén már 1997-ben folytak kutatások a IPv6 hálózatok kiépítésének tesztelésére. A NIIF által üzemeltetett és fejlesztett felsőoktatási és kutatói hálózaton 2001-ben kezdődtek meg az IPv6-os kísérletek és 2005 óta szolgáltatásként elérhető az IPv6 az egyetemek, kutatóintézetek és közgyűjtemények számára. Tarr Kft. 2007. november 8-tól kezdődően használ IPv6 címeket kiszolgáló infrastruktúráján. Lakossági tesztidőszak 2015 -től. Teljes DOCSIS lefedő egységesen 2018 évben lett IPv6 képes. Az Externet 2009. május 19-én zárta le a közel egyéves tesztidőszakot és azóta nyújtja rendes szolgáltatásként az IPv6-ot. A Magyar Telekom 2009. november 2-án kezdte meg hálózatában az IPv6 nyilvános tesztelését. A Magyar Telekom 2011. június 3-án kapcsolta be az IPv6 hálózatát teszt jelleggelIPv6 átkapcsolás és 2016 év végétől bevezette lakossági ügyfelei részére az IPv6 dual-stack szolgáltatását minden hozzáférési technológián: mobil, xDSL, GPON, DOCSIS.IPv6 a Magyar Telekomnál A HGW 1db /56 IPv6 prefixet kap, melyet az ügyfelek által telepített routerek használhatják prefix delegálás keretében további interfészeik IP címmel ellátására.IPv6-os hálózatok - Magyar Telekom csoport A Digi Kft. 2015. december 1-én elkezdte használni az FTTH hálózatán az IPv6-os IP címeket is.

Az IPv6 legfontosabb jellemzői

300px|bélyegkép|Az IPv6 csomag fejléce A protokoll tervezésekor nemcsak az IPv4 hibáit igyekeztek megszüntetni, hanem új szolgáltatásokat is bele kívántak építeni, amelyek gyorsabbá és az új felhasználói igényeknek jobban megfelelővé teszik.

Az IPv6 legfontosabb jellemzői: megnövelt, nagyobb címtartomány, közvetlen végponti címezhetőség, automatikus konfiguráció, vagyis a munkaállomások automatikus hálózati konfigurálását támogató rendszer végzi hálózati mobilitás, egy hálózati csatolóhoz egy időben több címet rendelhetünk. Ez hasonló a mobilszolgáltatók roamingRoaming: mobiltelefonunkkal külföldön a megfelelő területre érve a telefon automatikusan kiválaszt egy ottani szolgáltatót. Bárhol vagyunk mindig ugyanazon a telefonszámon vagyunk elérhetők és úgy tudunk onnan telefonálni, mintha otthon lennénk. (barangolási) szolgáltatásához. titkosítás, azonosítás: Az IPv6-címzés szerves része az IPsec biztonsági protokoll, ez hálózati szinten nyújt lehetőséget arra, hogy a kommunikációban részt vevő felhasználók hitelesen azonosítsák egymást, és az egymás közt zajló adatforgalmat titkosítsák egy biztonságos úgynevezett alagúton, tunnel-en keresztül anélkül, hogy az Internetről bárki le tudná hallgatni őket. többszörös címezhetőség, szabványosított multicastA multicast olyan összeköttetési mód, amely a hagyományos (unicast) csatlakozástól eltérően nem két gép, hanem tetszőleges számú gépből álló csoport tagjai között teremt kapcsolatot nagy sávszélességet igénylő adatforgalomban. A multicast címzésnek megfelelően az adatokat nem külön gépekre, hanem csoportcímre küldik, ezáltal sávszélesség-megtakarítás jön létre.

Az átállás az IPv4-ről IPv6-ra nem tud az egész Interneten egy időben lezajlani, ezért szükséges, hogy a két rendszer egymás mellett működhessen, akár az Interneten vagy a gépen belül is. Ezt az átmenetet a kompatibilis címek (az IPv4 címek egyszerűen átalakíthatók IPv6-címekké), és a különféle alagutak alkalmazása biztosítja. Használható egy kettős protokollcsomag, (dual stack IP ) nevű technika is, amely mindkét protokollt egy időben támogatja. A két teljesen különálló hálózati alrendszer és a két különböző protokollverzió nincs hatással egymásra.

Az IPv6 előnyei a végfelhasználó számára

Az IPv6 amellett, hogy a jelenlegi dinamikus IP-cím kiosztás helyett minden végfelhasználó kaphat egy fix IP-címet, a biztonság terén is hoz újításokat a jelenleg használt IPv4-hez képest. A 128 bites címtartomány több ezer milliárd eszköz számára biztosíthat IP-címet, így gyakorlatilag kimeríthetetlen a kapacitása. Lefordítva ezt a háztartásokra, az otthonokban minden internetképes eszköz önálló IP-címet kaphat, így azok zavar nélkül kommunikálhatnak egymással. Ha az eszközök az internethez kapcsolódnak, akár a fűtőberendezéseket vagy a mosógépet is bekapcsolhatjuk mobiltelefonunkon keresztül.

Sokan magát az IPv6-ot tekintik „killer application”-nek, mint ami megteremti a hálózatcentrikus világ létrehozásának lehetőségét. Ideális esetben az IPv6 használata a végfelhasználó számára láthatatlan marad. Az egyetlen változás, hogy az internetezés egyes esetekben egyszerűbbé válhat, illetve megjelennek majd olyan szolgáltatások/alkalmazások melyek IPv4 alapon csak igen bonyolult módon lennének nyújthatóak . Az IPv6 a végfelhasználó szempontjából egy ajtó, mely megteremti a lehetőséget a változásra. Éppen úgy, mint ahogyan anno a vezetékes világban a DSL, vagy a mobil világában a 3G megjelenése indított el egy-egy kommunikációs forradalmat.

IPv6 szabványok és migrációs stratégiák

Az IPv6-ra vonatkozó, annak alapvető működését rögzítő szabványok az IETF szervezetében születnek. Ugyanakkor érdemes nyomon követni más szabványosítási szervezetek munkáját is, hiszen fontos irányelveket fogalmaznak meg például a Broadband Forum (BBF) munkacsoportjai, melyek a meglévő szabványokon alapuló szolgáltatói környezet tekintetében rögzítenek ajánlásokat.

Az IPv6-bevezetési megoldások tekintetében számos eltérő – a szabványosítás különböző fázisában lévő – metódus látott napvilágot (pl. 6to4, 6rd, DS-lite, Softwire, Carrier Grade NAT, stb.). Az egyes megoldásoknak természetesen eltérő előnyei ill. hátrányai vannak, így folyamatos vitatémát biztosítanak a szakértők számára. Egyetértés van azonban a tekintetében, hogy a felhasználók számára egyidejűleg kell mind IPv4, mind IPv6 kapcsolódást biztosítani. Az ilyen megoldást nevezik dual-stack elérésnek. A dual-stackDual-stack:IP (kettős protokollcsomag) megoldás egyik fő előnye, hogy nincs szükség IPv4 és IPv6 hálózati átjárók létrehozására, melyek segítségével a csak egyik vagy másik verziót támogató végpontok kommunikálni tudnának egymással.

Címzés IPv6-tal

A legfontosabb tulajdonsága az IPv6-nak az IPv4-hez képest szinte elképzelhetetlenül nagy címtér. Az IPv6-címek 128 bit hosszúak, szemben az előd 32 bitjével.RFC 4291 IP Version 6 Addressing Architecture, R. Hinden, S. Deering (February 2006) Míg az IPv4 címtér körülbelül 4,3 milliárd címet tartalmaz, az új verzió nagyjából 340 szextillió (1036) egyedi címet foglal magába.

Az IPv6 címeket nyolc darab négy hexadecimális számjegyet tartalmazó csoportként ábrázoljuk, melyeket kettősponttal választunk el. Például: 2001:0db8:85a3:0000:0000:8a2e:0370:7334. A címeket logikailag két részre oszthatjuk, a 64 bites (al)hálózati előtagra, és a 64 bites interfész azonosítóra.

Az SLAAC működéséhez az alhálózatoknak legalább 264 nagyságú (/64) címtérre van szükségük. Az internetszolgáltatók (ISP-k) legalább 232 (/32) tartományokat kapnak. A végfelhasználók pedig /48, vagy egyes esetekben csak /56 tartományokat.

Az IPv6 címek három csoportba sorolhatóak: az unicast címek egyedileg azonosítanak egy interfészt; az anycast címek egy csoport interfészt azonosítanak, amelyek általában nem egy helyen vannak és amelyek közül a legközelebbi kerül automatikusan kiválasztásra; és a multicast címek, amelyek segítségével egy csomagot több interfésznek címezhetünk. Szórási címeket nem implementáltak az IPv6-ban. Minden IPv6 címnek van egy hatóköre (scope), ami megadja, hogy a hálózat mely részében érvényes és egyedi az adott cím. Egyes címek csak a helyi (al)hálózaton egyediek, mások globálisan azok.

Néhány IPv6 cím speciális célokra van fenntartva, mint például a visszacsatolási cím. Ezen kívül vannak speciális címtartományok is, például a kapcsolati szintű (link-local) címek a helyi hálózatban való használatra, és a solicited-node multicast címek, amelyeket a Neighbor Discovery Protocol használ.

IPv6 a domain nevek rendszerében

A DNS-ben a hosztnevet az AAAA erőforrás rekordokkal kapcsoljuk az IPv6 címekhez. A reverse DNS kérésekhez az IETF az ip6.arpa domaint jegyezte be, ahol a névtér hierarchikusan osztódik az IPv6 cím hexadecimális számjegyeinek egyjegyű nibble egységei szerint (4 bit). Ezt az RFC 3596 definiálja.

Címformátum

Az IPv6 címeknek két logikai része van: a 64 bites hálózati előtag, és a 64 bites hoszt azonosító. (Az utóbbit gyakran automatikusan generáljuk az interfész MAC címéből.) Leggyakrabban kettőspontokkal 8 csoportra tagolt 16 bites hexadecimális számként ábrázoljuk, a következőképpen:

fe80:0000:0000:0000:0202:b3ff:fe1e:8329 A hexadecimális számok nem kis-nagybetű érzékenyek.

A 128 bites IPv6 címet a következő szabályok szerint lehet rövidíteni: minden 16 bites csoportban elhagyhatjuk a bevezető 0-kat. Például az fe80:0000:0000:0000:0202:b3ff:fe1e:8329 cím írható így is: fe80:0:0:0:202:b3ff:fe1e:8329. Címenként egy alkalommal az egymást követő csak nullákból álló csoportokat rövidíthetjük két darab kettősponttal. Így az fe80:0:0:0:202:b3ff:fe1e:8329 cím rövidítve fe80::202:b3ff:fe1e:8329 lesz.

IPv6 cím biztosítására szolgáló mechanizmusok

A végpontok számára az IPv6 globális cím ill. prefix biztosítására többféle dinamikus megoldás létezik:

SLAAC: StateLess Address AutoConfiguration (RFC4862) DHCPv6: Dynamic Host Configuration Protocol for IPv6 (RFC3315) DHCPv6-PD: Prefix Delegation options (RFC3633)

A SLAAC módszer használatával a végpont a használandó IPv6-os címeit a lokálisan rendelkezésre álló ill. az adott hálózati szegmensre kapcsolódó router által hirdetett információkból generálja. A router az adott linkhez tartozó subnet prefixet hirdeti, míg a végpont egy az adott linken egyedi interface azonosítót generál. Az IPv6-os cím a két rész összeillesztéséből áll elő. Router hiányban a végpontok csak link lokális címeket tudnak generálni és csak az adott linkre kapcsolódó végpontok tudnak egymással kommunikálni.