IPv4 (Internet Protocol version 4) è la quarta revisione dell'Internet Protocol. Il protocollo è descritto nell'RFC 791, pubblicato dalla IETF nel settembre 1981, ed è il più usato a livello di rete, poiché fa parte della suite di protocolli Internet.

Nel 1998 è stata suggerita una nuova versione del protocollo Internet, denominata IPv6, a causa del problema della saturazione di IPv4. Al 2021, l'IPv6 risulta tuttavia meno utilizzato rispetto alla versione 4.

Struttura del pacchetto Un pacchetto IPv4 è composto da una sezione header e da una sezione data.

Header Lheader del pacchetto IPv4 consiste in 14 campi di cui 1 opzionale chiamato con il nome di Options. I campi sono inseriti col byte più significativo messo per primo (notazione big-endian) e all'interno dei singoli byte il bit più significativo è il primo (quello di indice 0).

Offsets Ottetto0123 Ottetto Bit012345678910111213141516171819202122232425262728293031 0 0VersionIHLDSCPECNTotal length432IdentificationFlagsFragment offset864Time to liveProtocolHeader checksum1296Source address16128Destination address20160Options (se IHL > 5)⋮⋮56448

Indica la versione del pacchetto IP: per IPv4, ha valore 4 (da qui il nome IPv4);

Indica la lunghezza (in word da ) dellheader del pacchetto IP ovvero l'offset del campo dati; tale lunghezza può variare da () a () a seconda della presenza e della lunghezza del campo facoltativo Options

Originariamente definito come type of service (ToS), questo campo specifica i differentiated services (DiffServ). La trasmissione di dati in tempo reale fa uso del campo DSCP. Un esempio è voice over IP (VoIP), che viene utilizzato per servizi vocali interattivi.

Questo campo permette una notifica end-to-end della congestione della rete senza perdita di pacchetti. ECN è una funzionalità opzionale disponibile quando entrambi gli endpoint la supportano ed è efficace quando anche la rete sottostante la supporta.

Indica la dimensione (in byte) dell'intero pacchetto, comprendendo header e dati; tale lunghezza può variare da un minimo di (header minimo e campo dati vuoto) ad un massimo di . In ogni momento, ad ogni host è richiesto di essere in grado di gestire datagrammi aventi una dimensione minima di mentre sono autorizzati, se necessario, a frammentare datagrammi di dimensione maggiore

Utilizzato, come da specifiche iniziali, per identificare in modo univoco i vari frammenti in cui può essere stato "spezzato" un pacchetto IP. Alcune sperimentazioni successive hanno però suggerito di utilizzare questo campo per altri scopi, come aggiungere la funzionalità di tracciamento dei pacchetti;

Bit utilizzati per il controllo del protocollo e della frammentazione dei datagrammi: Reserved - sempre settato a 0. Come pesce d'aprile, in RFC 3514 si è proposto di utilizzarlo come evil bit; DF (don't fragment) - se settato a 1 indica che il pacchetto non deve essere frammentato; se tale pacchetto non può essere inoltrato da un host senza essere frammentato, viene semplicemente scartato. Questo può risultare utile per "ispezionare" la capacità di gestione dei vari host del percorso di routing; MF (more fragments) - se settato a 0 indica che il pacchetto è l'ultimo frammento o il solo frammento del pacchetto originario, pertanto tutti gli altri suoi frammenti hanno il bit MF settato a 1. Naturalmente, questo bit sarà sempre 0 anche in tutti i datagrammi che non sono stati frammentati.

Indica l'offset (misurato in blocchi di 8 byte) di un particolare frammento relativamente all'inizio del pacchetto IP originale: il primo frammento ha offset 0. L'offset massimo risulta pertanto pari a che, includendo l'header, potrebbe eccedere la dimensione massima di di un pacchetto IP;

Indica il tempo di vita (time to live) del pacchetto, necessario per evitarne la persistenza indefinita sulla rete nel caso in cui non si riesca a recapitarlo al destinatario. Storicamente il TTL misurava i "secondi di vita" del pacchetto, mentre ora esso misura il numero di "salti" da nodo a nodo della rete: ogni router che riceve il pacchetto prima di inoltrarlo ne decrementa il TTL (modificando di conseguenza anche il campo header checksum), quando questo arriva a zero il pacchetto non viene più inoltrato ma scartato. Tipicamente, quando un pacchetto viene scartato per esaurimento del TTL, viene automaticamente inviato un messaggio ICMP al mittente del pacchetto, specificando il codice di richiesta scaduta; la ricezione di questo messaggio ICMP è alla base del meccanismo di traceroute;

Indica il codice associato al protocollo utilizzato nel campo dati del pacchetto IP: per esempio al protocollo TCP è associato il codice 6, ad UDP il codice 17, mentre ad IPv6 è associato il codice 41 (nel caso di tunnel IPv4-IPv6). La lista dei codici dei vari protocolli, inizialmente definita in RFC 790, è mantenuta e gestita dalla Internet Assigned Numbers Authority.

È un campo usato per il controllo degli errori dellheader. Ad ogni hop, il checksum viene ricalcolato (secondo la definizione data in RFC 791) e confrontato con il valore di questo campo: se non c'è corrispondenza il pacchetto viene scartato. È da notare che non viene effettuato alcun controllo sulla presenza di errori nel campo data deputandolo ai livelli superiori;

Indica l'indirizzo IP associato all'host del mittente del pacchetto. Da notare che questo indirizzo potrebbe non essere quello del "vero" mittente nel caso di traduzioni mediante NAT (anche in questo caso il router dovrà ricalcolare il valore dell'header checksum e sostituirlo a quello presente nell'header ricevuto). Infatti, qualora un host intermedio effettui questa traduzione, sostituisce l'indirizzo del mittente con uno proprio, premurandosi poi di ripristinare l'indirizzo originario su tutti i messaggi di risposta che gli arrivano destinati al mittente originario;

Indica l'indirizzo IP associato all'host del destinatario del pacchetto e segue le medesime regole del campo source address;

Opzioni (facoltative e non molto usate) per usi più specifici del protocollo, come informazioni sui router; Si ricorda che il valore del campo IHL deve essere sufficientemente grande da includere anche tutte le opzioni e, nel caso queste siano più corte di una word, il padding necessario a completare i . Inoltre, nel caso in cui la lista di opzioni non coincida con la fine dellheader, occorre aggiungere in coda ad essa un marcatore EOL (end of options list). C'è da notare infine che, potendo causare problemi di sicurezza, l'uso delle opzioni LSSR e SSRR (loose e strict source and record route, componenti del source routing) è scoraggiato e molti router bloccano i datagrammi che contengono queste opzioni.

Data Il payload del pacchetto non è incluso nel checksum. Il suo contenuto viene interpretato in base al valore del campo dell'intestazione protocollo.

Alcuni dei protocolli payload più comuni includono: Numero di protocolloNome del protocolloAbbreviazione1Internet Control Message ProtocolICMP2Internet Group Management ProtocolIGMP6Transmission Control ProtocolTCP17User Datagram ProtocolUDP41IPv6 encapsulationENCAP89Open Shortest Path FirstOSPF132Stream Control Transmission ProtocolSCTP

Indirizzamento IPv4 L'indirizzo IPv4 è formato da , esso è univoco sulla rete di cui fa parte. Tale indirizzo, inoltre, non va assegnato all'host, ma alle connessioni fisiche alla rete che l'host possiede (nel cast di host multicollegati o di dispositivi di rete). Si è però verificato che i primi paesi in cui si è diffuso Internet e all'interno di essi i primi provider, si sono "accaparrati" un numero di IP proporzionalmente sbilanciato. Gli ultimi provider hanno pertanto dovuto ricorrere ad un sistema per ovviare alla scarsità degli IP a loro attribuiti. Hanno pertanto considerato gli utenti a loro connessi di una intera città come un'unica LAN e pertanto tutti dotati dello stesso IP.

Concettualmente l'indirizzo IP si compone di due parti:

identificatore di rete e/o della sottorete; identificatore di host. +Bit di reteBit di host

Notazione decimale puntata Per semplificarne la lettura, ogni indirizzo IPv4 viene descritto con 4 numeri in base decimale, in modo che ognuno rappresenti un byte (il valore di un byte varia da 0 a 255 quando lo consideriamo in base dieci), separati dal simbolo "punto"; un esempio di indirizzo IPv4 è 192.0.34.166.

Indirizzi particolari Ogni indirizzo in cui l'identificativo host presenta tutti 0 è un indirizzo di rete, mentre se tutti i bit della parte host sono a 1, l'indirizzo si riferisce ad una trasmissione broadcast diretta.

Ad esempio: 192.168.1.0 (.0 in binario è 00000000) è un indirizzo di rete, mentre 192.168.1.255 (.255 in binario è 11111111) è di broadcast (supponendo che i primi tre byte identifichino la rete e solo il quarto identifichi gli host).

In pratica quando ad un router arriva un pacchetto in cui la parte di host dell'indirizzo presenta tutti i bit a 1, esso esegue un broadcast a tutti i nodi della sotto-rete. Questo comportamento è stato sfruttato dai cracker per creare attacchi di tipo denial of service, pertanto è buona norma disabilitare nei router l'inoltro del broadcast diretto.

Indirizzamento a classi

Se un host deve comunicare con un altro host della stessa sottorete, userà il protocollo di livello 2 della rete a cui è collegato, altrimenti dovrà inviare i pacchetti ad un gateway o router, che sarà connesso ad altre reti e si occuperà di inoltrare i pacchetti ricevuti.

La comunicazione tra i router avviene mediante indirizzi IP utilizzando delle tecniche particolari di indirizzamento per individuare la sottorete e l'host.

Originariamente lo schema delle suddivisioni delle due componenti era a classi per cui un indirizzo IP apparteneva una classe (classfull) in base ai primi dell'IP.

Con questo schema l'indirizzo è ad autoidentificazione perché il confine tra le due componenti si può determinare con i bit più significativi.

Limiti

Il numero di indirizzi univoci disponibili in IPv4 è , ma bisogna tener presente che non vengono usati tutti, perché alcuni sono riservati a un particolare utilizzo (ad esempio gli indirizzi 0.0.0.0, 127.0.0.1, 255.255.255.255, 192.0.34.166 e la classe 192.168.0.1/16) e perché certe classi non vengono sfruttate interamente per via della suddivisione interna in classi più piccole.

L'indirizzamento a classi, proprio per questo, presenta diversi limiti dovuti soprattutto al numero di host gestibili dalle diverse classi.

In pratica se si esauriscono gli indirizzi univoci resi disponibili da una classe, ad esempio la C connettendo più di 255 host, occorre fare ricorso ad un indirizzo di classe superiore.

Il cambiamento di indirizzo non è indolore con questa tecnica perché il software di rete va aggiornato con i nuovi indirizzi e non consente una transizione graduale.

In pratica l'indicatore di rete univoco non poteva adempiere alle esigenze della crescita che negli anni ottanta ebbero le reti LAN. Quindi per risparmiare i prefissi di rete si dovettero escogitare altre tecniche come quella del mascheramento (vedi NAT) per continuare a fare in modo che IPv4 potesse adempiere al suo ruolo prima dell'entrata di IPv6.

Indirizzamento senza classi L'indirizzamento in classi è considerato obsoleto e per permettere un migliore sfruttamento degli indirizzi IP disponibili, è stato introdotto l'indirizzamento senza classi (classless), o CIDR.

La modifica introdotta dal CIDR consiste essenzialmente nell'utilizzare maschere di sottorete di lunghezza arbitraria, mentre l'indirizzamento con classi ammetteva solo tre lunghezze della maschera di sottorete: /8, /16 e /24. La maschera della vecchia classe C (/24) è ancora popolare, ma si usano anche maschere più corte per reti grandi (/23 o /22) o più lunghe per reti piccole (/25, /26, fino a /30 per reti punto-punto).