A expressão "adoptar, estender e extinguir", também conhecida como "Adoptar, estender e exterminar" (em inglês: Embrace, extend and extinguish) é uma frase que o Departamento de Justiça estado-unidense alega ter sido usada internamente pela Microsoft para descrever sua estratégia de lançar produtos envolvendo padrões amplamente usados, estendendo esses padrões com funções proprietárias e incompatíveis e então usar essas diferenças para por seus concorrentes em desvantagem.

Origem A estratégia a frase "adoptar e estender" foram descritos pela primeira vez fora da Microsoft em 1996 no New York Times, artigo intitulado "Amanhã, a World Wide Web! Microsoft, o rei PC, quer reinar através da internet", em que o escritor John Markoff disse: "Ao invés de simplesmente adoptar e estender a internet, os críticos da empresa temem agora, a Microsoft tem a intenção de afundá-los." A frase "adoptar e estender" também aparece em uma canção motivacional jocosa do empregado da Microsoft Dean Ballard, em uma entrevista de Steve Ballmer para New York Times.Steve Lohr, "Preaching from the Ballmer Pulpit". New York Times, Sunday, January 28, 2007. pp. 3-1, 3-8, 3-9.

A variação "adoptar, estender e extinguir", foi introduzido pela primeira vez no julgamento antitruste Estados Unidos v. Microsoft quando o vice-presidente da Intel, Steven McGeady, testemunhou (DOC format) que o vice-presidente da Microsoft Paul Maritz usou a frase em uma reunião de 1995 com a Intel para descrever a estratégia da Microsoft em direção a Netscape, Java, e a internet.

A estratégia Três fases da estratégia são: Adoptar: Desenvolvimento de software substancialmente compatível com um produto concorrente, ou a implementação de um padrão público. Estender: Adição e promoção dos recursos não suportados pelo produto concorrente ou parte do padrão, criando problemas de interoperabilidade para os clientes que tentam usar o padrão "simples". Extinguir: Quando as extensões tornam-se um padrão de fato por causa da sua quota de mercado dominante, eles marginalizariam os concorrentes que não possam ou não queiram suportar as novas extensões.

O Departamento de Justiça dos EUA, os críticos da Microsoft, e jornalistas da indústria de computador afirmam que o objetivo da estratégia é monopolizar uma categoria de produto. Tal estratégia difere da estratégia originalmente proposta por J. Allard "adoptar, estender então inovar" tanto no conteúdo como fases. A Microsoft alega que a estratégia original não é anti-competitiva, mas sim um exercício do seu poder discricionário para implementar recursos que ela acredita que os clientes querem.

Exemplos Incompatibilidades no navegador: Os demandantes no caso antitruste alegou que a Microsoft tinha adicionado suporte para controles ActiveX no Internet Explorer para quebrar compatibilidade com Netscape Navigator, que usou componentes baseados em Java e o sistema Netscape de plugin. O CSS, dados:, etc.: Uma década após a ação antitruste relacionada com o Netscape, a empresa Opera Software apresentou uma queixa antitruste contra a Microsoft na União Europeia dizendo que "chamandos a Microsoft para aderir a seus próprios pronunciamentos públicos para apoiar estas normas, em vez de sufocar-las com sua notória estratégia "adoptar, estender e extinguir".Opera files antitrust complaint with the EU Em documentos do Office: Em um memorando ao grupo de produtos do Office em 1998, Bill Gates declarou: "Uma coisa que nós temos que mudar ou permitir a estratégia dos documentos do Office redirecionem muito bem outras navegadores é uma das coisas mais destrutivas que poderíamos fazer para a empresa. Nós temos que parar de colocar qualquer esforço para isso e certifique-se que documentos do Office muito bem da compatibilidade PROPRIEDADE DO IE. Qualquer outra coisa é um suicídio para a nossa plataforma. Este é um caso em que o Office tem de evitar fazer algo para destruir o Windows." [Ênfase no original]A memo to the Office product group A quebra de portabilidade com Java: Os demandantes do caso antitruste também acusaram a Microsoft de usar uma estratégia de "adoptar e estender" no que diz respeito à plataforma Java, que foi concebida de forma explícita com o objetivo de desenvolver programas que poderiam funcionar em qualquer sistema operacional, seja ele Windows, Mac ou Linux. Alegaram que, omitindo a Java Native Interface (JNI) a partir de sua implementação e fornecendo J/Direct para um propósito semelhante, a Microsoft deliberadamente amarrou programas do Windows Java para sua plataforma, tornando-as inutilizáveis em sistemas Linux e Mac. De acordo com uma comunicação interna, a Microsoft procurou minimizar compatibilidade multiplataforma Java e torná-la "apenas o mais recente, o melhor caminho para escrever aplicativos do Windows". A Microsoft pagou a Sun US $ 20 milhões em Janeiro de 2001 (26,6 milhões dólares nos termos atuais) para resolver as implicações jurídicas resultantes de sua violação de contrato. Mais questões sobre Java: Sun processou a Microsoft sobre Java novamente em 2002 e Microsoft concordou em resolver fora dos tribunais para US$ 2 bilhões (2620 milhões dólares em termos de hoje). Networking: Em 2000, uma extensão para o protocolo de rede Kerberos (um padrão da Internet) foi incluído no Windows 2000, negando eficazmente todos os produtos, exceto aqueles feitos pela Microsoft acessando um Windows 2000 Server usando o Kerberos. A extensão foi publicada junto a um executável, cuja execução exigiu concordar com NDA, não permitindo implementação por terceiros (especialmente código aberto). Para permitir que desenvolvedores para implementem os novos recursos, sem ter de concordar com a licença, os usuários do Slashdot publicaram o documento (desconsiderando o NDA), permitindo efetivamente desenvolvedores de terceiros acessem a documentação sem ter concordado com NDA. A Microsoft respondeu pedindo ao Slashdot para remover o conteúdo.. As extensões da Microsoft para Kerberos, introduziram o formato binário no Windows 2000, já foram descritos na RFC 3244 e RFC 4757, e estas extensões já foram listados na Microsoft Open Specification Promise. Este documento refere-se a "Microsoft-owned ou Microsoft-controlled patentes que são necessárias para implementar" as tecnologias listadas. Declaração legal da Microsoft sobre o uso irrestrito de propriedade intelectual da Microsoft também inclui o Kerberos Network Authentication Service v5 (RFC 1510 e RFC 1964). Mensagens instantâneas: Em 2001, CNet News.com descreve um exemplo sobre o programa de mensagens instantâneas da Microsoft. "Adoptar" protocolo de mensagens instantâneas da AOL, o padrão de fato da década de 90 e início de 2000. "Estender" o padrão com addons proprietárias da Microsoft, que acrescentou novos recursos, mas quebrou a compatibilidade com software da AOL. Ganhar o domínio desde que a Microsoft tinha 95% de participação do OS e seu MS Messenger foi fornecido gratuitamente. E finalmente, "extinguir" e bloquear software de mensagens instantâneas da AOL, uma vez que a AOL não pôde utilizar o modificado protocolo MS patenteado. Medos da Adobe: Adobe Systems se recusou a deixar a Microsoft implementar PDF com suporte built-in no Microsoft Office, citando os medos da EEE.CIO: Adobe Speaks Out on Microsoft PDF Battle As versões atuais do Microsoft Office têm suporte built-in para PDF, bem como várias outras normas e padrões ISO. Testemunho de empregado: Em 2007, o empregado da Microsoft Ronald Alepin deu testemunho de especialistas para os demandantes para Comes v. Microsoft no qual ele citou e-mails internos da Microsoft para justificar a alegação de que a empresa intencionalmente empregava esta prática.Expert Testimony of Ronald Alepin in Comes v. Microsoft—Embrace, Extend, Extinguish, Groklaw, January 8, 2007.

Variante Uma variante mais antiga da frase é "adoptar, prorrogar, em seguida, inovar" de J Allard no memorando de 1994 "Windows: The Next Killer Application on the Internet" para Paul Maritz e outros executivos da Microsoft. A nota começa com um plano de fundo na internet em geral, e, em seguida, propõe uma estratégia sobre como ativar o Windows para ser o próximo "aplicativo matador" para a internet:

Outras companhias e a Microsoft Durante a guerra dos navegadores, outras empresas além da Microsoft introduziram extensões não compatíveis com os padrões. Em 1995, por exemplo, a Netscape implementou a tag "font", entre outras extensões HTML, sem buscar a avaliação de um organismo de normalização. Com a ascensão do Internet Explorer, as duas empresas ficaram travadas em um empate para implementar características não compatíveis com padrões. Em 2004, para evitar a repetição de uma "guerra dos navegadores" e do pântano resultante de normas conflitantes, a Apple Inc. (fabricante do Safari), Mozilla Foundation (fabricante do Firefox), Google Inc. (fabricante do Google Chrome) e Opera Software (fabricante do Opera browser) formaram a Web Hypertext Application Technology Working Group (WHATWG) para criar padrões abertos para complementar aqueles do World Wide Web Consortium. A Microsoft originalmente recusou-se a participar, citando como razão a falta de uma política de patentes do grupo. No entanto, atualmente a Microsoft Corporation está listada como membro deste grupo.

Ver também Halloween documents Críticas a Microsoft Medo, incerteza e dúvida Efeito de rede Aprisionamento tecnológico Caminho da dependencia

Notas de rodapé e referências

Ligações externas

Categoria:Interoperabilidade Categoria:Ciência da computação Categoria:Críticas e controvérsias sobre a Microsoft Categoria:Tecnologia da informação