thumb|Um diagrama de alguns servidores e clientes Usenet. Os pontos azuis, verdes e vermelhos nos servidores representam quais grupos eles armazenam. Setas entre servidores indicam que os servidores compartilham artigos dos grupos. Setas entre clientes e servidores indica que o usuário subscreve um determinado grupo, recebendo e enviando artigos de/para o servidor. O Usenet (do inglês, Unix User Network) é um meio de comunicação onde usuários postam mensagens de texto (chamadas de "artigos") em fóruns que são agrupados por assunto (chamados de grupos de notícias). Ao contrário das mensagens de correio eletrónico, que são transmitidas quase que diretamente do remetente para o destinatário, os artigos publicados nos grupos de notícias são retransmitidos através de uma extensa rede de servidores interligados.
O surgimento da rede data de 1979 e a maioria dos computadores participantes naquela época se comunicava através de conexões discadas por um protocolo chamado de UUCP, mas com a popularização da Internet nas décadas de 80 e 90 o sistema passou a funcionar quase que completamente baseado no protocolo NNTP da família de protocolos TCP/IP. O software InterNetNews é hoje o servidor mais utilizado para conectar as máquinas que fazem parte da rede Usenet.
Introdução A Usenet trata-se de uma das mais antigas redes de comunicação por computador ainda em uso generalizado.
Foi concebida em 1979 e estabelecida publicamente em 1980 na Universidade da Carolina do Norte em Chapel Hill a na Duke University, mais de uma década antes da World Wide Web ter sido desenvolvida e o acesso público à Internet ter sido disponibilizado. Tendo sido baseada originalmente na ARPANET, fazendo uso do UUCP como protocolo de transporte, para oferecer serviço de correio a transferências de arquivos, segundo anúncios haveria um serviço de notícias como o A News. O nome USENET enfatizava, segundo seus criadores, a esperança de que a organização USENIX tivesse um papel ativo no funcionamento do serviço.Stephen Daniel, James Ellis, and Tom Truscott (1980). USENET - A General Access UNIX Network. (inside archive as usenet/uprop.n)
Os textos publicados pelos usuários são organizados dentro de categorias chamadas grupos de notícias, que são organizados por hierarquias de assuntos. Por exemplo, sci.math e sci.physics estão dentro da hierarquia sci, ou seja, assuntos científicos. Quando um usuário subscreva para um grupo de notícias o software novo cliente organiza os artigos que o usuário tenha lido.Lehnert, Wendy G.; Kopec, Richard (2007). Web 101. Addison Wesley. p. 291.
Nos grupos, a maioria dos textos são respostas para algum outro texto. O conjunto de artigos que podem ser rastreados para um único artigo sem resposta é chamado de lista de discussão. Muitos dos modernos leitores de notícia organizam artigos da mesma forma, em tópicos e sub-tópicos. Assim que um usuário posta um artigo, o texto ficará disponível inicialmente apenas no servidor onde o usuário está conectado. Cada servidor informa aos outros que houve uma mudança em um artigo, que informam essas mudanças para os outros servidores, em cascata. Dessa forma os artigos são copiados de um servidor para outro, até que todos tenham uma cópia do novo texto. Esse mesmo modelo é aplicado em redes peer-to-peer, mas para a Usenet é normalmente o remetente, ao invés do receptor, que inicia as transferências.
Usenet teve uma significativa importância cultural na sociedade virtual, popularizando ou informando grande variedade de conceitos e termos, os famosos "FAQ" e "spam" são bons exemplos.
Hoje, Usenet tem diminuído em importância em relação aos fórums, blogues e listas de correio eletrónico. A diferença, contudo, é que este sistema de troca de informações não requer registro com o grupo de interesse. Os arquivos estão sempre disponíveis e a leitura de mensagens não requer um cliente de email ou web (mas um cliente de notícias). Em sua maior parte, esta foi substituída pela Internet como a conhecemos hoje, mas ainda hoje tem um grande número de utilizadores.
A Usenet foi originalmente criada para distribuir conteúdo de texto codificado no conjunto de caracteres ASCII de 7 bits. Com a ajuda de programas que codificam os valores de 8 bits em ASCII, tornou-se prática a distribuição de ficheiros binários. As mensagens binárias, devido ao seu tamanho e ao facto de não ser possível confirmar que o direito de cópia era assegurado, foram restritas a Newsgroups específicos, tornando-se mais fácil para os administradores permitir ou não o seu tráfego.
O método mais antigo de codificação utilizado para conteúdo binário é uuencode, baseado em UUCP Unix. No final da década de 1980, as submissões na Usenet foram muitas vezes limitadas a 60.000 caracteres, e ainda maiores limites existem hoje. Os ficheiros são, portanto, geralmente divididos em secções que requerem, posteriormente, a sua junção por parte do leitor.
Leitores (newsreader) Os grupos de notícias são acessados tipicamente com newsreaders: aplicação que permite ao usuário ler e responder a publicações nos grupos de notícias. Esses aplicativos atuam como clientes para um ou mais servidores de notícias. Embora historicamente a Usenet fosse associada com o sistema operacional Unix desenvolvido na AT&T, newsreaders estão disponíveis para todos os principais sistemas operacionais. Clientes de e-mail modernos ou "suítes de comunicação" tem comumente integradas um newsreader. Muitas vezes, porém, esses clientes integrados são de baixa qualidade, em comparação com newsreaders independentes, e implementam incorretamente protocolos, normas e convenções da Usenet. Muitos desses clientes integrados, são detestados pelos puristas por causa de seu mau comportamento.
Com o surgimento da World Wide Web (WWW), web front-ends (web2news) tornaram-se mais comuns. Com os web front-ends diminuiu-se as barreiras técnicas dos aplicativos Usenet. Existem inúmeros sites que oferecem portais baseados na web para grupos Usenet, mas por uma razão ou outra algumas pessoas começaram a filtrar mensagens feitas por algumas dessas interfaces. Google Groups é uma dessas front-end baseadas na web e alguns navegadores da Web podem acessar o Google Groups via news.
Grupos de notícias moderados e não-moderados Uma minoria dos grupos de notícias são moderados, ou seja, as mensagens enviadas não são distribuídas diretamente para a Usenet, mas sim, enviadas para o moderador do newsgroup para serem aprovadas. Os moderadores são responsáveis por receber os artigos enviados, revê-los e enviar os que foram aprovados, permitindo assim eles se propaguem pelo mundo. Artigos aprovados por um moderador precisam ter na linha de cabeçalho: Aprovado. Moderadores garantem que as mensagens que os leitores vêem no grupo de notícias estão em conformidade com as regras do grupo de notícias, embora eles não são obrigados a seguir tais regras ou orientações. Normalmente, os moderadores são designados na proposta para o newsgroup, e as mudanças de moderadores seguem um plano de sucessão.
Existia uma hierarquia mod.* antes da Usenet ser reorganizada. Agora, os grupos de notícias moderados podem aparecer em qualquer hierarquia.
Newsgroups na hierarquia Big-8 são criados por propostas chamadas de Pedido de Discussão, ou RFD (Request for Discussion). O RFD é obrigado a ter as seguintes informações: nome do grupo de notícias, checkgroups, o estado de moderação (se o grupo deve ser moderado, então deve ser fornecido pelo menos um moderador com um endereço de correio eletrónico válido). Outras informações que são importantes, mas não exigidas incluem: uma licença, uma justificativa e uma política de moderação, se o grupo deve ser moderado. A discussão de uma nova proposta de newsgroup termina com os membros do Conselho de Administração do Big-8 que tomam a decisão, por voto, para aprovar ou desaprovar o novo grupo de notícias.
Newsgroups sem moderação formam a maioria dos grupos de notícias da Usenet, onde as mensagens enviadas são imediatamente propagadas para todo mundo ver. A filtragem mínima de conteúdo X a propagação de forma rápida são um ponto crucial da comunidade Usenet. Uma pequena defesa contra a propagação é o cancelamento de uma mensagem propagada, mas poucos usuários da Usenet usam este comando e alguns leitores não oferecem comandos de cancelamento, em parte por causa da rápida expiração do artigo armazenado. A criação de grupos de notícias moderados, muitas vezes torna-se um assunto controverso, levantando questões sobre a censura e o desejo de um subconjunto de usuários.
Detalhes técnicos A Usenet é um conjunto de protocolos para a geração, o armazenamento e a recuperação de notícias, "artigos" (que se assemelham a mensagens de e-mail) para sua posterior troca entre um público que está, potencialmente, amplamente distribuído. Esses protocolos usam mais comumente um algoritmo que propaga cópias para todos os servidores de uma rede. Sempre que uma mensagem chega a um servidor, esse servidor envia a mensagem para todos os servidores na rede que ainda não possuem o artigo. Apenas uma cópia de uma mensagem é armazenada por servidor, e cada servidor torna disponível sob demanda para os leitores (geralmente locais). O conjunto de servidores Usenet, portanto, tem um caráter de uma conexão peer-to-peer em que eles compartilham recursos, trocando-os, a granularidade de troca, porém, é em uma escala diferente de um moderno sistema de peer-to-peer e essa característica exclui os usuários reais do sistema que se conectam aos servidores de notícias com uma típica aplicação cliente-servidor, como um leitor de correio eletrónico.
A RFC 850 foi a primeira especificação formal das mensagens trocadas pelos servidores da Usenet. Ela foi substituída pela RFC 1036 e, posteriormente, pela RFC 5536 e RFC 5537.
Nos casos em que conteúdo inadequado foi publicado, Usenet tem suporte para remoção automática de uma postagem de toda a rede, criando uma mensagem de cancelamento, embora, devido à falta de autenticação e abuso, esta capacidade é frequentemente desativada. Detentores de direitos autorais ainda podem solicitar a eliminação manual do material ilícito com base nas disposições da Organização Mundial da Propriedade Intelectual.
Na Internet, a Usenet é transportada através do protocolo NNTP (Network News Transfer Protocol) na porta TCP 119 por padrão, para conexões não protegidas e na porta TCP 563 para conexões criptografadas (SSL).
Organização O principal conjunto de newsgroups em todo o mundo está contido em nove hierarquias, das quais oito são operados sob as diretrizes consensuais que regem a sua administração e nomeação.
As oito são:
comp.* – discussões relacionadas com computador. (comp.software, comp.sys.amiga) humanities.* – artes plásticas, literatura e filosofia (humanities.classics, humanities.design.misc) misc.* – temas diversos (misc.education, misc.forsale, misc.kids) news.* – discussões e anúncios sobre news (sobre a Usenet, e não eventos atuais) (news.groups, news.admin) rec.* – recreação e entretenimento (rec.music, rec.arts.movies) sci.* – discussões relacionadas com a ciência (sci.psychology, sci.research) soc.* – discussões sociais (soc.college.org, soc.culture.african) talk.* – falar sobre vários temas controversos (talk.religion, talk.politics, talk.origins)
A hierarquia alt.* não está sujeita aos procedimentos de controle da Big Eight, como resultado é menos organizada.
Grupos na hierarquia alt.* tendem a ser mais especializados ou específicos, por exemplo, pode haver um grupo de notícias sob a Big Eight que contém discussões sobre livros infantis, mas um grupo na hierarquia alt.* pode ser dedicado a um autor específico de livros para crianças. Arquivos binários são postados em alt.binaries.*, tornando-a a maior de todas as hierarquias.