Na informática, o IPv6 (sigla de Protocolo de Internet versão 6) é a versão mais atual do Protocolo de Internet (IP), um padrão de intercomunicação de rede na internet (TCP/IP e OSI) sucessor do IPv4 oficializada em 2012, a implementado pelo grupo IETF no padrão RFC 2460, com regras inicialmente feitas por Scott Bradner e Allison Marken em 1994 na RFC 1752. Criado devido ter muitos dispositivos computacionais conectados à internet.

O protocolo está sendo implantado gradativamente na internet e deve funcionar por algum tempo lado a lado com o IPv4, na situação tecnicamente chamada de "pilha dupla" ("dual stack"). A longo prazo, o IPv6 tem como objetivo substituir o IPv4, que suporta somente cerca de 4 bilhões(escala curta)/mil milhões(escala longa) (4x109) de endereços IP, contra cerca de 340 undecilhões(escala curta)/sextilhões(escala longa) (3,4x1038) de endereços do novo protocolo.

O assunto é tão relevante que alguns governos têm apoiado essa implantação. O governo dos Estados Unidos, por exemplo, em 2005, determinou que todas as suas agências federais deveriam provar ser capazes de operar com o protocolo IPv6 até junho de 2008. Em julho de 2008, foi liberada uma nova revisão das recomendações para adoção do IPv6 nas agências federais, estabelecendo a data de julho de 2010 para garantia do suporte ao IPv6. O governo brasileiro recomenda a adoção do protocolo no documento e-PING, dos Padrões de Interoperabilidade de Governo Eletrônico.

IPv6 tem apresentado crescimento significativo na adoção mundial, especialmente impulsionado por grandes empresas de tecnologia e provedores de internet, além de destacar seu papel na expansão da Internet das Coisas (IoT).

As informações que trafegam pela internet são divididos em pacotes, e cada um contém o endereço de identificação IP do remetente e do destinatário.

História O IPv6, versão atual do padrão IP e sucessor do IPv4, foi originalmente oficializada em 6 de junho de 2012 como fruto do esforço do grupo Internet Engineering Task Force (IETF), para criar a "nova geração do IP" (IPng: Internet Protocol next generation), cujas linhas mestras foram descritas por Scott Bradner e Allison Marken em 1994 no documento técnico RFC 1752. Sua principal especificação encontra-se na especificação RFC 2460<.

Motivações para a implantação

O esgotamento do IPv4 e a necessidade de mais endereços na Internet O principal motivo para a implantação do IPv6 na Internet é a necessidade de mais endereços IP, porque a disponibilidade de endereços livres IPv4 terminou, devido o crescimento rápido de dispositivos computacionais conectados.

Para entender as razões desse esgotamento, é importante considerar que a Internet não havia sido projetada para uso comercial. No início da década de 1980, ela era considerada uma rede predominantemente acadêmica, com poucas centenas de computadores interligados. Apesar disso, pode-se dizer que o espaço de endereçamento do IP versão 4, de 32 bits, não é pequeno: de endereços.

Ainda assim, já no início de sua utilização comercial, em 1993, acreditava-se que o espaço de endereçamento da Internet poderia se esgotar num prazo de 2 ou 3 anos. Mas, não por causa da limitada quantidade de endereços, e sim por conta da política de alocação inicial, que não era favorável a uma utilização racional desses recursos. Dividiu-se esse espaço em três classes principais (embora atualmente existam, a rigor, cinco classes), a saber:

Classe A: com 128 segmentos/redes, que poderiam ser atribuídos individualmente às entidades que deles necessitassem, com aproximadamente 16 milhões de endereços cada. Essa classe era classificada como /8, pois os primeiros 8 bits representavam a rede, ou segmento, enquanto os demais poderiam ser usados livremente. Ela utilizava o espaço compreendido entre os endereços 00000000.*.*.* (0.*.*.*) e 01111111.*.*.* (127.*.*.*). Classe B: com aproximadamente 16 mil segmentos de 64 mil endereços cada. Essa classe era classificada como /16. Ela utilizava o espaço compreendido entre os endereços 10000000.0000000.*.* (128.0.*.*) e 10111111.11111111.*.* (191.255.*.*). Classe C: com aproximadamente 2 milhões de segmentos de 256 endereços cada. Essa classe era classificada como /24. Ela utilizava o espaço compreendido entre os endereços 11000000.0000000.00000000.* (192.0.0.*) e 110111111.11111111.11111111.* (213.255.255.*).

Os 32 blocos /8 restantes foram reservados para Multicast e para a IANA (Internet Assigned Numbers Authority), entidade que controla a atribuição global dos números na Internet.

O espaço reservado para a classe A atenderia a apenas 128 entidades, no entanto, ocupava metade dos endereços disponíveis. Não obstante, empresas e entidades como HP, GE, DEC, MIT, DISA, Apple, AT&T, IBM, USPS, dentre outras, receberam alocações desse tipo.

As previsões iniciais, no entanto, de esgotamento quase imediato dos recursos, não se concretizaram devido ao desenvolvimento de uma série de tecnologias, que funcionaram como uma solução paliativa para o problema trazido com o crescimento acelerado:

O CIDR (Classless Inter Domain Routing), ou roteamento sem uso de classes, que é descrito pela RFC 1519. Com o CIDR foi abolido o esquema de classes, permitindo atribuir blocos de endereços com tamanho arbitrário, conforme a necessidade, trazendo um uso mais racional para o espaço. O uso do NAT (Network Address Translation) e da RFC 1918, que especifica os endereços privados, não válidos na Internet, nas redes corporativas. O NAT permite que, com um endereço válido apenas, toda uma rede baseada em endereços privados, tenha conexão, embora limitada, com a Internet. O DHCP (Dynamic Host Configuration Protocol), descrito pela RFC 2131. Esse protocolo trouxe a possibilidade aos provedores de reutilizarem endereços Internet fornecidos a seus clientes para conexões não permanentes.

O conjunto dessas tecnologias reduziu a demanda por novos números IP, de forma que o esgotamento previsto para a década de 1990, foi postergado para a década de 2010. Porém, a adoção mundial do IPv6 é lenta: de acordo com o Google, a adoção mundial do IPv6 foi de 2% em 2014, de 5% em 2015, de 8% em 2016, de 14% em 2017, de 20% em 2018, de 25% em 2019, de 30% em 2020, de 33% em 2021 e de 35% em 2022; de acordo com o APNIC, a adoção mundial do IPv6 foi de 2% em 2014, de 3% em 2015, de 5% em 2016, de 9% em 2017, de 16% em 2018, de 19% em 2019, de 24% em 2020, de 27% em 2021 e de 29% em 2022.

Outros motivos O principal fator que impulsiona a implantação do IPv6 é sua necessidade na infraestrutura da Internet. É uma questão de continuidade de negócios, para provedores e uma série de outras empresas e instituições.

Contudo, há outros fatores que motivam sua implantação:

Internet das Coisas: Imagina-se que, em um futuro onde a computação seja ubíqua, a tecnologia estará presente em vários dispositivos atualmente ainda não inteligentes, que serão capazes de interagir autonomamente entre si - computadores invisíveis interligados à Internet, embutidos nos objetos usados no dia a dia - tornando a vida ainda mais líquida. Pode-se imaginar eletrodomésticos conectados, automóveis, edifícios inteligentes, equipamentos de monitoramento médico, etc. Dezenas, talvez mesmo centenas ou milhares de equipamentos estarão conectados em cada residência e escritório. O IPv6, com endereços abundantes, fixos, válidos, é necessário para fazer desse futuro uma realidade. Expansão das redes: Vários fatores motivam uma expansão cada vez mais acelerada da Internet: a inclusão digital, as redes móveis (3G, 4G, 5G), etc. São necessários mais IPs. Qualidade de serviço: A convergência das redes de telecomunicações futuras para a camada de rede comum, o IPv6, favorecerá o amadurecimento de serviços hoje incipientes, como VoIP, streaming de vídeo em tempo real, etc, e fará aparecerem outros, novos. O IPv6 tem um suporte melhorado a classes de serviço diferenciadas, em função das exigências e prioridades do serviço em causa. Mobilidade: A mobilidade é um fator muito importante na sociedade de hoje em dia. O IPv6 suporta a mobilidade dos utilizadores, estes poderão ser contactados em qualquer rede através do seu endereço IPv6 de origem.

Novidades nas especificações

Espaço de Endereçamento. Os endereços IPv6 têm um tamanho de 128 bits. Autoconfiguração de endereço. Suporte para atribuição automática de endereços numa rede IPv6, podendo ser omitido o servidor de DHCP a que estamos habituados no IPv4. Endereçamento hierárquico. Simplifica as tabelas de encaminhamento dos roteadores da rede, diminuindo assim a carga de processamento dos mesmos. Formato do cabeçalho. Totalmente remodelados em relação ao IPv4: mais simplificado e eficiente. Cabeçalhos de extensão. Opção para guardar informação adicional. Suporte à qualidade diferenciada. Aplicações de áudio e vídeo passam a estabelecer conexões apropriadas tendo em conta as suas exigências em termos de qualidade de serviço (QoS). Capacidade de extensão. Permite adicionar novas especificações de forma simples. Encriptação. Diversas extensões no IPv6 permitem, à partida, o suporte para opções de segurança como autenticação, integridade e confidencialidade dos dados.

Formato do datagrama IPv6 Um datagrama IPv6 é constituído por um cabeçalho base, ilustrado na figura que se segue, seguido de zero ou mais cabeçalhos de extensão, seguidos depois pelo bloco de dados.

centro|400x400px|Cabeçalho base do datagrama IPv6 Formato do cabeçalho base do datagrama IPv6:

Possui menos informação que o cabeçalho do IPv4. Por exemplo, o checksum foi removido do cabeçalho, já que esta versão considera que o controle de erros das camadas inferiores é confiável. O campo Traffic Class (8 bits) é usado para assinalar a classe de serviço a que o pacote pertence, permitindo assim dar diferentes tratamentos a pacotes provenientes de aplicações com exigências distintas. Este campo serve de base para o funcionamento do mecanismo de qualidade de serviço (QoS) na rede. O campo Flow Label (20 bits) é usado com novas aplicações que necessitem de bom desempenho. Permite associar datagramas que fazem parte da comunicação entre duas aplicações. Usados para enviar datagramas ao longo de um caminho pré-definido. O campo Payload Length (16 bits) representa, como o nome indica, o volume de dados em bytes que pacote transporta. O campo Next Header (8 bits) aponta para o primeiro header de extensão. Usado para especificar o tipo de informação que está a seguir ao cabeçalho corrente. O campo Hop Limit (8 bits) tem o número de hops transmitidos antes de descartar o datagrama, ou seja, este campo indica o número máximo de saltos (passagem por roteadores) do datagrama antes de ser descartado. Esse campo substitui o TTL do IPv4. O campo Source Address (128 bits) indica o endereço de origem do pacote. O campo Destination Address (128 bits) indica o endereço de destino do pacote.

Fragmentação e determinação do percurso No IPv6, o responsável pela fragmentação é o host que envia o datagrama, e não os roteadores intermédios como no caso do IPv4. No IPv6, os roteadores intermédios descartam os datagramas maiores que o MTU da rede. O MTU será o MTU máximo suportado pelas diferentes redes entre a origem e o destino. Para isso o host envia pacotes ICMP de vários tamanhos; quando um pacote chega ao host destino, todos os dados a serem transmitidos são fragmentados no tamanho deste pacote que alcançou o destino.

O processo de descoberta do MTU tem que ser dinâmico, porque o percurso pode ser alterado durante a transmissão dos datagramas.

No IPv6, um prefixo não fragmentável do datagrama original é copiado para cada fragmento. A informação de fragmentação é guardada num cabeçalho de extensão separado. Cada fragmento é iniciado por uma componente não fragmentável seguida de um cabeçalho do fragmento.

Múltiplos cabeçalhos